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Installation Guide 

For Plentymarkets Novalnet Payment Plugin 
Version Date Remarks 
12.2.0 06.05.2025 [New] Implemented TWINT payment 

[Fix] Google pay button is displayed properly when Other payment provider are 

active 

[Fix] Novalnet transaction details are updated when creating an invoice using 

Document Builder 

 [Enhanced] Extension of Instalment Payment cycles till 36 cycles 

[Enhanced] Offering Instalment payments and Guarantee payments to B2B 

customers in Switzerland 

[Enhanced] Alert email notification for successful transactions to the store 

owner for missing orders 

[Enhanced] Built-in Sub-Resource Integrity (SRI) integrated for JavaScript files 

to improve security for preventing unauthorized modifications 

[Enhanced] Minification of  JavaScript files for enhanced performance 

[Enhanced] Optimized the Callback/Webhook process for fetching Dynamic IP 

[Enhanced] Novalnet payment plugin has been optimized for new testcase 

 

  

mailto:technic@novalnet.de


 

          

 

2 

NOVALNET AG 

Payment Institution 

Gutenbergstr. 7 

D-85748 Garching 

Tel.: +49 89 9230683-19 

Fax: +49 89 9230683-11 

E-Mail: technic@novalnet.de 

Tax id: DE254954139 

Board of Directors: Gabriel Dixon (CEO), Johnson Rajdaniel (CFO) 

Chairman of the supervisory Board: Frank Haussmann 

Commercial register number: HRB 167381 

TABLE OF CONTENTS 

1 QUICK SETUP ........................................................................................................................................4 

1.1 Plugin Installation ..........................................................................................................................4 

1.1.1 Installation via Marketplace.........................................................................................................4 

1.1.2 Installation via GIT .......................................................................................................................6 

1.2 Plugin activation ............................................................................................................................6 

1.3 Updating the Novalnet Payment Plugin ..........................................................................................7 

1.4 Global Configuration in the Plentymarkets shop system.................................................................8 

1.5 Notification / Webhook configuration in the Novalnet Admin Portal ............................................10 

1.6 Client key configuration in the Novalnet Admin Portal .................................................................10 

1.7 Payment Activation in the Novalnet Admin Portal ........................................................................12 

1.8 Payment Activation in the plentymarkets shop system ................................................................15 

2 TESTING AND GOING LIVE ...................................................................................................................16 

3 ADDITIONAL CONFIGURATION ...........................................................................................................17 

3.1 Additional configuration for all the payment methods .................................................................17 

3.2 Additional configuration for Credit/Debit Cards ...........................................................................20 

3.3 Additional configuration for Google Pay Payment ........................................................................20 

3.4 Multilingualism ............................................................................................................................20 

4 MANAGING ORDERS ...........................................................................................................................23 

4.1 Order overview ..............................................................................................................................23 

4.2 Display transaction details and Initiate Payment in shop Front-End................................................23 

4.3 Admin order creation.....................................................................................................................25 

5 INITIATE PAYMENT .............................................................................................................................30 

5.1 Initiate with same payment method ..............................................................................................30 

5.2 Initiate with Change payment methods .........................................................................................30 

5.3 Disable the Initiate Payment ..........................................................................................................31 

6 MANAGING PLENTYMARKET EVENT CREATION ..................................................................................31 

6.1 Confirm a transaction ....................................................................................................................31 

6.2 Cancel a transaction ......................................................................................................................34 

6.3 Refund a transaction ......................................................................................................................35 

mailto:technic@novalnet.de


 

          

 

3 

NOVALNET AG 

Payment Institution 

Gutenbergstr. 7 

D-85748 Garching 

Tel.: +49 89 9230683-19 

Fax: +49 89 9230683-11 

E-Mail: technic@novalnet.de 

Tax id: DE254954139 

Board of Directors: Gabriel Dixon (CEO), Johnson Rajdaniel (CFO) 

Chairman of the supervisory Board: Frank Haussmann 

Commercial register number: HRB 167381 

6.4 Refund the transaction using Credit note .......................................................................................36 

6.4.1 Partial refund process via Credit note ........................................................................................37 

6.4.2 Full refund process via Credit note ............................................................................................38 

6.5 Invoice PDF Generation .................................................................................................................39 

6.6 Instalment Cancellation Options ....................................................................................................40 

6.6.1 Cancel All Instalment ..................................................................................................................40 

6.6.2 Cancel All Remaining Instalment .................................................................................................42 

7 PLUGIN DEACTIVATION AND DELETION ..............................................................................................44 

7.1 Deactivation ................................................................................................................................44 

7.2 Deletion .......................................................................................................................................44 

8 TECHNICAL SUPPORT THROUGH NOVALNET.......................................................................................44 

  

 

 

 

  

 

 

 

 

 

  

mailto:technic@novalnet.de


 

          

 

4 

NOVALNET AG 

Payment Institution 

Gutenbergstr. 7 

D-85748 Garching 

Tel.: +49 89 9230683-19 

Fax: +49 89 9230683-11 

E-Mail: technic@novalnet.de 

Tax id: DE254954139 

Board of Directors: Gabriel Dixon (CEO), Johnson Rajdaniel (CFO) 

Chairman of the supervisory Board: Frank Haussmann 

Commercial register number: HRB 167381 

1 QUICK SETUP 
This guide describes the quick installation procedure of Novalnet payment plugin in your shop system and to 

start accepting payments worldwide. For this integration, a Novalnet merchant account is needed to accept 

Novalnet payments, so please make sure that you have received your merchant account details from our sales 

team. If not, drop a mail to sales@novalnet.de 

This Novalnet payment plugin version (12.2.0) supports the following versions: 

 
plentyShop LTS IO 

7.0.0 4.0.1 - 5.0.71 4.0.1 - 5.0.71 

To get started:   

1. Log in to the Novalnet Admin Portal with your merchant account details (user credentials)  

2. Log in to your plentymarkets admin panel. 

3. Make sure that you have purchased the payment plugin package from the Plentymarket Marketplace. 

Refer topic 1.1.1 and 1.1.2 in this guide for installing the payment plugin into your shop system. If you 

have received only the installation guide without the payment plugin package (zip file), please mail us 

at technic@novalnet.de with your merchant ID. 

1.1 Plugin Installation 

1.1.1 Installation via Marketplace 

To install the Novalnet Payment Plugin, go to your shop admin panel and follow the steps below. 

Step 1: Navigate to Plugins → plentyMarketplace as shown below. 

 
Figure 1 

Step 2: Go to Plugins → Payment Integrations in the plentymarkets marketplace to choose the payment 

plugin. 

 
Figure 2 
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Search for Novalnet payment plugin in the search bar and select it. 

 
Figure 3 

Click Go to checkout to purchase the plugin for free.  

 
Figure 4 

Then, click Order now to complete the purchase.  

 
Figure 5 

Once the plugin is purchased you will receive a success message as shown below. 

 
Figure 6 

The plugin comes free and you will not be asked to pay for the plugin.

Follow the steps under topic 1.2 Plugin activation for activating the Novalnet payment plugin in your 

plentymarkets shop system. 
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1.1.2 Installation via GIT 

To install the Novalnet payment plugin in your shop system via Git, follow the steps below. 

Navigate to Plugins → Git in the shop admin panel as shown below. 

 
Figure 7 

Click Add new Repository  icon as shown below, 

 
Figure 8 

Enter the Username and Token under Add credentials and enter the Repository under Add repository and 

then click SAVE button to establish the connection. 

 
Figure 9 

If you don’t have the details kindly contact technic@novalnet.de / tel. +49 89 9230683-19 to get the Git 

repository details (Username and Token, Repository). 

After installation, follow the steps under topic 1.2 Plugin activation for activating the Novalnet payment 

plugin for plentymarkets shop system. 

1.2 Plugin activation 

Navigate to Plugins → Plugin set overview in the shop admin panel and click the Standard Shop plugin set. 

 
Figure 10 

 
Figure 11 
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Next, click  icon and search for Novalnet payment to add Novalnet payment to the shop system. 

 
Figure 12 

Choose the preferred version of Novalnet payment plugin and click the  icon as shown below. .

 
Figure 13 

Click enable  switch to activate the Novalnet payment plugin. 

 
Figure 14 

After the Novalnet payment plugin is activated, Deploy the plugin set as shown below. 

 
Figure 15 

1.3 Updating the Novalnet Payment Plugin 

Follow the below steps to update the latest Novalnet payment plugin from the shop admin panel. 

Step 1: Navigate to Plugin set overview as shown in Figure 1 to find the Novalnet payment plugin. 

Step 2: Click the Update  icon under Actions as shown below. 

 
Figure 16 

After the plugin update, the latest version of Novalnet Payment plugin will be updated and deploy the plugin 

set in your shop system. 

 
Figure 17 

 If the Novalnet Payment plugin version is above 12.0.0, client key configuration is required to 

authenticate your client based requests. Refer to chapter 1.6 for more information.  
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1.4 Global Configuration in the Plentymarkets shop system 

For Novalnet plugin configuration, in your shop admin panel navigate to Setup → Assistants → Plugins → 

standard-shop → Novalnet → Client Id: Standard Shop→ Novalnet API Configuration as shown below. 

 
Figure 18 

To get your merchant details, go to the Novalnet Admin Portal, navigate to Projects menu and click View icon 

on the right of your project to view the project details. 

 
Figure 19 

Click API credentials and copy the Product Activation key, Payment Access key, Tarif ID’s and Client key. 

 
Figure 20 
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Paste the Product Activation key, Payment Access key, Tarif ID’s and Client key in the respective fields in your 
shop admin panel and click “NEXT” as shown below. 

 
Figure 21 

Then click “FINALISE” on the Summary page to save the configurations as shown below. 

 
Figure 22 

Payment before order completion 

This is the default setting - By enabling this option, orders will be created in the shop system before the 

transaction succeeds. 

 
Figure 23 
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1.5 Notification / Webhook configuration in the Novalnet Admin Portal 

In the Novalnet Admin Portal, go to Projects → Select Project → API credentials and under Vendor script URL 

/ Notification & Webhook URL click Edit as shown below. 

 
Figure 24 

Next enter the vendor script URL appended with your shop URL and click update. In general, the vendor script 

URL will be like <YOUR SITE URL>/payment/novalnet/webhook 

 
Figure 25 

In your shop system, you can also manually test the Webhook URL manually and send notification emails 

to specific email address mentioned here. 

 
Figure 26 

 Allow manual testing of the Notification / Webhook URL - Enable this to test the Novalnet Notification 

/Webhook URL manually. Disable this before setting your shop system live, to block unauthorized calls 

from external parties. 

 Send e-mail to - Every execution will be sent as a message to the e-mail address defined in this field. 

1.6 Client key configuration in the Novalnet Admin Portal  

The client key is a unique key which is linked with your Novalnet merchant account to authenticate your client 

based requests. You need the client key to render the secure payment form and tokenize (temporarily) the 

sensitive information.  

 Novalnet allows client-side request(s) only from the whitelisted domains under a particular project
in the Novalnet Admin Portal. The domain must be a valid (secured https://) website. Please follow the below 

steps to whitelist the domains in the Novalnet Admin Portal under a single client key.

mailto:technic@novalnet.de
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Step 1: Go to the Novalnet Admin Portal with your Novalnet merchant account details. 

Step 2: Navigate to the Projects menu and choose your project as shown below. 

 
Figure 27 

Step 3: On the project details page click API credentials and click  beside Allowed Domain(s) on the 

Client key field as shown below. 

 
Figure 28 

Step 4: Paste your website URL in the Domain name field and click  as shown below. 

 
Figure 29 

Step 5: After adding the Domain name, the web URL will be listed under Allowed Domain(s) as shown below. 

 
Figure 30 
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1.7 Payment Activation in the Novalnet Admin Portal 

All the Novalnet supported payment methods can be viewed here: www.novalnet.com/payment. If you have 

queries about the payment methods or have additional payment method requests, please contact 

sales@novalnet.de 

To activate the preferred payment methods for your website, go to the Novalnet Admin Portal, and navigate 

to the Projects → Payment Methods → Edit Payment Methods in the top right corner as shown below. 

 
Figure 31 
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Now enable the preferred payment methods and click Update to activate them as shown below. 

  
Figure 32 

To use the Apple Pay payment method, navigate to Apple Pay → Configure → Add new domain in the 

Novalnet Admin Portal as shown below. 

 
Figure 33 
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Then, paste https://paygate.novalnet.de domain to enable Apple Pay, and click Verify as shown below. 

 
Figure 34 

To use the PayPal payment method, configure the PayPal API details in Novalnet Admin Portal as shown 

below. 

 
Figure 35 

To use the PostFinance payment method, configure Ep2-Merchant ID details in Novalnet Admin Portal as 

shown below. 

 
Figure 36 
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1.8 Payment Activation in the plentymarkets shop system 

After activating the payment methods in the Novalnet Admin Portal, you must enable these payment 

methods in your shop admin panel to display them on your plentymarkets checkout page. 

Follow the below steps: 

Step 1: Navigate to Setup → Assistance → Plugins → Standard-Shop → Novalnet → Client Id: Standard 

Shop→ {Select a desired payment method}  

Step 2: Click Enable payment method checkbox to activate the payment method then Click NEXT and click 

“FINALISE” on the Summary page to save the changes made. 

 
Figure 37 

Step 3: Navigate to Setup → CRM → Classes → choose the particular customer class to select the ALLOWED 

PAYMENT METHODS  

 
Figure 38 

Step 4: Select the payment methods and click the save  icon as shown below. 

 
Figure 39 
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After adding the preferred payment methods, they will appear in the shop front end as shown below. 

 
Figure 40 

Refer chapter 3 ADDITIONAL CONFIGURATION for more payment configurations. 

 If you have any recommendations or suggestions for improvement, kindly share your thoughts with us to 

develop our payment plugins further to technic@novalnet.de or call us at +49 89 9230683-19.  

 Are you happy with our service and support? Please spend a few minutes to share your success here. 

2 TESTING AND GOING LIVE 
Execute test transactions by navigating to Setup → Assistance → Plugins → Standard-Shop → Novalnet → 

Client Id: Standard Shop→ choose the specific payment method (e.g. Credit/Debit Cards) → click Enable test 

mode checkbox at each payment configuration page. Then, Click NEXT and click “FINALISE” on the Summary 

page to save the changes made. In the test mode the transaction amount will not be charged by Novalnet. 

  
Figure 41 

 Refer the below URL for Novalnet test payment data, 

https://developer.novalnet.com/testing/  

Execute orders in LIVE MODE 

To proceed with LIVE orders, don’t forget to disable the Enable test mode option for each separately in the 

payment configuration page. 

 If you have any recommendations or suggestions for improvement, kindly share your thoughts with us on 

technic@novalnet.de or call us at +49 89 9230683-19. 

 Are you happy with our service and support? Please spend a few minutes to share your success here. 
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3 ADDITIONAL CONFIGURATION 

3.1 Additional configuration for all the payment methods 

For additional payment configuration settings for each payment method, navigate to Setup → Assistants → 

Plugins → Standard-Shop → Novalnet → Client Id: Standard Shop→  and configure the required additional 

payment settings. 

Payment Action (Debit immediately / Reserve funds for later) 

 This option is available only for Credit/Debit Cards, Direct Debit SEPA, Direct Debit SEPA with payment 

guarantee, Instalment by Direct Debit SEPA, Invoice, Invoice with payment guarantee, Instalment by 

Invoice, PayPal, Google pay and Apple pay. 

 

You can choose between two options - Capture and Authorize which are both explained below, 

 Capture - This is the default setting where transactions are directly confirmed, and funds are automatically 

transferred from buyer’s account to the merchant account. This can be changed as per your business 

requirement. 

 
Figure 42 

 Authorize - Payment details are verified while the funds are reserved, which will be captured later.  

 Minimum transaction amount for authorization - Transactions from this amount will be “authorized” 

(reserved) only and captured later. Leave the field blank to authorize all transactions. 

  
Figure 43 

Payment due date (in days) 

Payment due date (in days) refers to the duration (number of days) given for buyer to complete the payment. 

The payment process and duration may differ for each payment method. 

 This option is  available only Direct Debit SEPA, Invoice, Prepayment, and Barzahlen/viacash.  

 
Figure 44 

 For Direct Debit SEPA, enter the number of days after which the payment is debited (must be between 3 

and 14 days). 

 For Invoice, enter the number of days given to the buyer to transfer the amount to Novalnet (must be 

greater than 7 days). If this field is left blank, 14 days will be set by default.  

 For Prepayment, enter the number of days given to the buyer to transfer the amount to Novalnet (must 

be greater than 7 days). If this field is left blank, 14 days will be set by default.  

 For Barzahlen/viacash, enter the number of days given to the buyer to pay at a store nearby. If this field is 

left blank, 14 days will be set by default for slip expiry. 
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Payment guarantee configuration 

When the basic requirements (as mentioned below) are met, Novalnet offers you the option to process 

payments as guarantee payments. For more information about Novalnet’s guarantee payments,  

Please visit: https://developer.novalnet.com/onlinepayments/aboutguarantee#basic-requirements 

 This option is available only for Direct Debit SEPA with payment guarantee and Invoice with payment 

guarantee. 

Force Non-Guarantee payment 

 This option is available only for the following payment methods: 

Direct Debit SEPA with payment guarantee and Invoice with payment guarantee. 

Enable this option to process payments as non-guarantee payment when the guarantee conditions are not 
met. 

 
Figure 45 

Minimum Order Amount 
Payments will be displayed on the checkout page, if the entered amount is equal to or greater than the total 

order amount (E.g., enter 100 which is equal to 1.00). 

 
Figure 46 

Maximum Order Amount 

Payments will be displayed on the checkout page, if the entered amount is equal to or lesser than the total 

order amount (E.g., enter 100 which is equal to 1.00). 

 
Figure 47 

Allowed Countries 

Payments will be displayed on the checkout page, if the billing address of the customer matches the country 

given in this field (E.g. DE, AT, CH, etc.) 

 
Figure 48 

Allow B2B Customers 

 This option is available only for Direct Debit SEPA with payment guarantee, Instalment by Direct Debit 

SEPA, Invoice with payment guarantee and Instalment by Invoice. 

Enabling this option will allow B2B buyers in your shop system.  

 
Figure 49 

  

mailto:technic@novalnet.de
https://developer.novalnet.com/onlinepayments/aboutguarantee#basic-requirements


 

          

 

19 

NOVALNET AG 

Payment Institution 

Gutenbergstr. 7 

D-85748 Garching 

Tel.: +49 89 9230683-19 

Fax: +49 89 9230683-11 

E-Mail: technic@novalnet.de 

Tax id: DE254954139 

Board of Directors: Gabriel Dixon (CEO), Johnson Rajdaniel (CFO) 

Chairman of the supervisory Board: Frank Haussmann 

Commercial register number: HRB 167381 

Instalment payments configuration 

When the basic requirements are met, Novalnet offers you the option to process payments as instalment 

payments. For more information about instalment payments and basic requirements,  

Please visit: https://developer.novalnet.com/onlinepayments/aboutinstalment#basic-requirements 

Instalment Cycles 

Instalment cycle refers to the pre-defined period for partial payments that allow the buyers to pay their full 

order amount in parts. The intervals or cycles vary based on shop admin configuration. 

This option is available only for Instalment by Direct Debit SEPA and Instalment by Invoice. 

Define which installment cycles you wish to offer in your shop (e.g. 2 cycles, 3 cycles, 4 cycles, 6 cycles, etc..) 

and click NEXT to confirm. The buyer can then choose among these instalment cycles, if they wish to pay in 

instalments. 

 
Figure 50 

The pre-defined instalment details will be visible for the buyer under the chosen instalment payment method 

as shown below. 

 
Figure 51 
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3.2 Additional configuration for Credit/Debit Cards 

Enforce 3D secure payment outside EU 

By enabling this option, all payments from cards issued outside the EU will be authenticated via 3DS 2.0 SCA. 

 
Figure 52 

Form appearance 

If you wish to change the default design of the Credit/Debit Card’s form (for example to use your corporate 

identity), you can do it here. Leave this field unchanged to use the default settings. 

 
Figure 53 

3.3 Additional configuration for Google Pay Payment 

Enforce 3D secure payment outside EU 

By enabling this option, all payments from cards issued outside the EU will be authenticated via 3DS 2.0 SCA. 

 
Figure 54 

Google Merchant ID 

Enter your Google’s merchant identifier for processing the payment method in live environment. 

 
Figure 55 

Button Type 

Select the button type for Google Pay from this drop-down. 

 
Figure 56 

Button Height 

Set the button height for Google Pay, range from 30 to 64 pixels. 

 
Figure 57 

3.4 Multilingualism 

Novalnet allows merchants to configure shop front-end content in multiple languages defined in the shop 

admin panel. Manage multiple languages for shop front-end texts such as the Payment name and Payment 

descriptions. Set up multiple language support by navigating to the menu Shop → Multilingualism. 

 
Figure 58 
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Select the Plugin set “E.g. standard-shop” from the drop-down list for which you want to edit text elements. 

 
Figure 59 

Select a preferred language Source language on the left and a Target language on the right side. 

 
Figure 60 

To customize the language text in Target language on the right, go to Novalnet → Customize by expanding 
the view. 

 
Figure 61 

You can see the default text displayed as per the source language under Target language. 

 
Figure 62 
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You can also change the form Template text and error messages to display in the plenty market checkout 

page by navigating to Novalnet → Template. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 63 

Finally, click  to save the data and then click  to publish the saved changes. 

 Supported source languages are German and English by default. 
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4 MANAGING ORDERS 
Navigate to shop admin panel and click Orders → Orders from the menu as shown below. 

 
Figure 64 

4.1 Order overview 

Click the Sales Order NO to find a detailed view of each order. 

 
Figure 65 

4.2 Display transaction details and Initiate Payment in shop Front-End 

To display the Novalnet transaction details in the shop front-end order history, go to shop admin panel and 

navigate to Plugins → Plugin set overview → Respective Plugin set “E.g. Standard-Shop” → Novalnet → 

Container links.  

 
Figure 66 

Click the Container links, and dropdown to the Data provider and enable the checkbox as shown below. 

 
Figure 67  
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 The corresponding Active container links will be displayed on the right pane when you enable the Order 

confirmation: Additional payment information under the Novalnet transaction details dropdown. 

 
Figure 68 

 When you enable the Order confirmation: Additional payment information dropdown under Novalnet 

Initiate Payment, and enable the checkbox Initiate Payment button will be displayed on the shop front-

end confirmation page for failure and rejected transactions. 

 
Figure 69 

 When you enable the Script loader: After scripts loaded dropdown under Novalnet Payment Script and 

enable the checkbox, the script loader for placing an order for failure and rejected transactions will be 

appended in the Initiate Payment button. 

    
Figure 70 
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 When you enable the Checkout: After “Order now” button dropdown under Novalnet Google Pay 

button and enable the checkbox, the Google Pay button will be displayed in shop front-end confirmation 

page for failure and rejected transactions. 

 
Figure 71 

Select the checkbox as highlighted in the above screenshot and click the save  icon to update / save the 

changes.

 It is mandatory to enable Script loader: After scripts loaded, if Order confirmation: Additional payment 

information is enabled the Initiate Payment button. 

4.3 Admin order creation 

To create an order from the shop admin panel, navigate to CRM → Contacts as shown below. 

 
Figure 72 

Search the respective end-user mail and select  option. Now choose Orders and select New order as shown 

below. 

 
Figure 73 
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Next, a new order tab will be appeared add invoice and delivery address. And choose the payment method in 

the drop down and select the warehouse. Then click ADD ITEMS as shown below. 

 
Figure 74 

 It is mandatory to give Email address for invoice and delivery address. 

Next search the respective product & add to cart. Then click OVERVIEW as shown below. 

 
Figure 75 

Next click CREATE ORDER, as shown below. 

 
Figure 76 
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Order is now successfully created and status history is updated in the shop admin panel as shown below. 

 
Figure 77 

Click the email icon to send the payment link email.  

 
Figure 78 

Select the appropriate email template from the Email service and click SEND. 

 
Figure 79 
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The email will be sent to the end-user, including the status link. 

 
Figure 80 

Click on the INITIATE PAYMENT to make a payment. 

 
Figure 81 

Once the order is successful, transaction information will display as shown below. 

 
Figure 82 
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To send an order confirmation e-mail to end user in the shop, an event has to be created. So to create an 
Event, navigate to Setup → Orders → Events and click the Add  icon to add an event procedure as shown 
below. 

 
Figure 83 

Now create an event for end-user confirmation email, enter the event name under the “Name” field and 

choose the event procedure (New order) for which you will trigger the order confirmation email. Finally, click 

the  icon as shown below. 

 
Figure 84 

After the event is created, click the filter  icon, select Payment method and Referrer filters. Next, click 

the filter  and search for Send email procedure. Choose the Store: Order confirmation email 

procedure as shown below. 

 
Figure 85 

Then, click the save   icon. 
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5 INITIATE PAYMENT 
Payment initiation is done for failed/declined transactions where new payment for the same order can be 

initiated with same or different payment method. Initiate payment button will be shown by default in the 

payment confirmation page. 

5.1 Initiate with same payment method 

Once a payment fails, you will be automatically redirected to the payment confirmation page. Click INITIATE 

PAYMENT in the payment confirmation page to initiate the previously failed payment. 

Figure 86 

 
Figure 87 

5.2 Initiate with Change payment methods 

Before re-initiating payment, you can change the payment method. Click the click here link beside Change 

payment method as shown below. 

 

 
Figure 88 

Next, an overlay is displayed with the list of payment methods to choose from. Choose the payment method 

and click CHANGE to update it for the upcoming transaction. 

 
Figure 89 
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5.3 Disable the Initiate Payment 

To disable/hide the Initiate Payment button, go to shop admin panel and click Plugins → Plugin set overview 

→ Respective Plugin set “E.g. standard-shop” → Novalnet → Container links as shown in Figure 65. 

Next, click this  icon next to Ceres::OrderConfirmation.AdditionalPaymentInformation under the Active 

container links as shown below. 

 
Figure 90 

6 MANAGING PLENTYMARKET EVENT CREATION 
To perform any action in the shop, an event has to be created. To create an Event, navigate to Setup → Orders 

→ Events and click the Add  icon to add an event procedure. 

 
Figure 91 

6.1 Confirm a transaction 

To create an event for confirming a transaction, enter the event name under the “Name” field. Choose the 

event procedure for which you will confirm the order.  Select an order status from the drop-down list for the 

event created and click the  icon as shown below. 

 
Figure 92 
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Select the created event and click the filter  icon as shown below. 

 
Figure 93 

Under Add filter, navigate to Order → Payment method and click the  icon as shown below. 

 
Figure 94 

Next, select the preferred payment methods under Payment method and click the  icon as shown below. 

 
Figure 95 
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Now, select the procedure Novalnet | Confirm under Plugins and click the  icon as shown below. 

 
Figure 96 

Then enable the Active checkbox and then click the save   icon. 

 
Figure 97 

To confirm an on-hold payment, navigate to Orders → Orders from the main menu. Click the order number 

and choose the status that triggers this event to confirm the order under the Status and Tags field as shown 

below. 

 
Figure 98 

Once the order has been confirmed, new payment ID created under Assigned payments. Click the payment 

ID the transaction update comments are available as shown below. 

 
Figure 99 
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6.2 Cancel a transaction 

To create an event for cancelling a transaction, enter the event name under the “Name” field. Choose the 

event procedure for which you will cancel the order. Select an order status from the drop-down list for the 

event created and click the  icon as shown below. 

 
Figure 100 

Repeat the steps as shown in the Figures 93, 94 and 95 to add payment methods for the event. 

Next, select the procedure Novalnet | Cancel under Plugins and click the  icon as shown below. 

 
Figure 101 

Then enable the Active checkbox and then click the save   icon as shown below. 

 
Figure 102 

To cancel an on-hold transaction, navigate to Orders → Orders from the main menu and click the order. Under 

Status and Tags, choose the order status that triggers the event to cancel the order. 

 
Figure 103 
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Once the order has been cancelled, new payment ID created under Assigned payments. Click the payment ID 

the transaction update comments are available as shown below. 

 
Figure 104 

6.3 Refund a transaction 

To create an event for refunding a transaction, enter the event name under the “Name” field. Choose the event 

procedure for which you will refund the order.  Select an order status from the drop-down list for the event 

created and click the  icon. 

 
Figure 105 

Repeats the steps as shown in the Figures 94, 95 and 96 to add payment methods for the event. 

Next, select procedure Novalnet | Refund under Plugins and click the  icon as shown below. 

 
Figure 106 

Then enable the Active checkbox and click the save   icon as shown below. 

 
Figure 107 
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You can refund the full order amount to the buyer. Refund can be initiated by navigating to Orders → Orders 

from the main menu and click the order. Under Status and Tags, choose the order status that triggers the event 

to refund the amount as shown below. 

 
Figure 108 

Once the order has been refunded, new payment ID created under Assigned payments. Click the payment ID 

the transaction update comments are available as shown below. 

 
Figure 109 

6.4 Refund the transaction using Credit note 

Enter the event name under the “Name” field. Choose the event procedure for the created event and click the 

 icon as shown below. 

 
Figure 110 

Repeat the steps as shown in the Figures 94, 95 and 96 to add payment methods for the event. 

Next, select procedure Novalnet | Refund under Plugins and click the  icon as shown below. 

 
Figure 111 
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Then enable the Active checkbox and click the save   icon as shown below. 

 
Figure 112 

6.4.1 Partial refund process via Credit note 

Select the relevant order, Click the   icon, and choose the Credit note → For specific order items in drop-

down menu as shown below. 

 
Figure 113 

After clicking the For specific order items in drop-down menu, new window will appear. Click the  icon as 

shown below. 

  
Figure 114 
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Reduce the product quantity for partial refund and click the save  icon to execute the partial refund for 

the particular order. 

 
Figure 115 

Once partial refund is completed a new child order will be created in the shop. 

Click the child order, the transition comments are updated under Assigned payments. Click the payment ID 

the transaction comments are available as shown below. 

 
Figure 116 

6.4.2 Full refund process via Credit note 

Select the relevant order, Click the   icon, and choose the Credit note → For all order items drop-down menu 

to proceed with the full refund. 

 
Figure 117 

Once a full refund is completed a new child order will be created in the shop. 
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Click the child order, the transition comments are updated under Assigned payments. Click the payment ID the 

transaction comments are available as shown below. 

 
Figure 118 

6.5 Invoice PDF Generation 

To create an event for generating an invoice PDF, enter the event name under the “Name” field. Choose the 

event procedure for which you will generate PDF for the order.  Select an order status for the event created 

and click the  icon as shown below. 

 
Figure 119 

Generate invoice for the orders to display payment transaction details in the invoice PDF except for the 

newly created events. 

Repeat the steps as shown in the Figures 94, 95 and 96 to add payment methods for the event. 

Next, select procedure Generate Invoice under Documents and click the  icon.  

 
Figure 120 

Then enable the Active checkbox and click the save   icon as shown below. 

 
Figure 121 
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Select the particular order and choose the Status to trigger the event that generates the invoice PDF. 

 
Figure 122 

Once the Status gets updated under order details, invoice pdf is generated in MAIN DOCUMENT field under 

General tab. Then click the view  icon to view the details in a PDF. 

 
Figure 123 

6.6 Instalment Cancellation Options 

6.6.1 Cancel All Instalment 

Create an event for cancelling all instalments. Provide an event name under the “Name” field. Choose the event 

procedure for which you wish to cancel the all instalments for the order. Select an order status from the drop-

down list for the event created and click the  icon as shown below. 

 
Figure 124 

Select the created event and click the filter  icon as shown below. 

 
Figure 125 
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Under Add filter, navigate to Order → Payment method and click the  icon as shown below. 

 
Figure 126 

Next, select the preferred payment methods under Payment method and click the  icon as shown below. 

 
Figure 127 

Now, select the procedure Novalnet | Cancel All Instalment under Plugins and click the  icon as shown 

below. 

 
Figure 128 
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Then enable the Active checkbox and then click the save   icon. 

 
Figure 129 

To cancel all instalments, navigate to Orders → Orders from the main menu. Click the order number and 

choose the status under the Status and Tags that triggers the event to cancel all instalments the order.  

 
Figure 130 

Once the order has been cancelled, new payment ID created under Assigned payments. Click the payment 

ID the transaction update comments are available as shown below. 

 
Figure 131 

6.6.2 Cancel All Remaining Instalment 

To cancel the remaining unpaid instalments create an event. Provide the event name under the “Name” field. 

Choose the event procedure for which you wish to cancel the remaining instalments  for the order. Select an 

order status from the drop-down list for the event created and click the  icon as shown below. 

 
Figure 132 

Repeat the steps as shown in the Figures 125, 126 and 127 to add payment methods for the event. 
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Next, select the procedure Novalnet | Cancel All Remaining Instalment under Plugins and click the  icon 

as shown below. 

 
Figure 133 

Then enable the Active checkbox and then click the save   icon as shown below. 

 
Figure 134 

To cancel all remaining instalments, navigate to Orders → Orders from the main menu and click the order. 

Under Status and Tags, choose the order status that triggers the event to cancel the remaining instalments for 

the order. 

 
Figure 135 

Once the order has been cancelled, new payment ID created under Assigned payments. Click the payment 

ID the transaction update comments are available as shown below. 

 
Figure 136 
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7 PLUGIN DEACTIVATION AND DELETION 

7.1 Deactivation 

Navigate to Plugins → Plugin set overview → choose Novalnet click  toggle to deactivate the plugin.  

 
Figure 137 

7.2 Deletion  

Under Actions, click the more option  icon to view the delete option. Click the  Delete plugin as shown 

below. 

 
Figure 138 

In the delete plugin pop up window that appears, type DELETE under CONFIRMATION FIELD and click Delete 

to delete the Novalnet payment plugin. 

       
                         Figure 139                                                                    Figure 140 

8 TECHNICAL SUPPORT THROUGH NOVALNET 
For any questions or further enquiries please contact one of the following departments as per your 

requirement. Our in-house experts are ready to assist you in case of queries or issues.  

For installation assistance contact technic@novalnet.de or call +49 89 9230683-19 

For a merchant account, new payment plugin or additional payment methods requests, please contact 

sales@novalnet.de or call +49 89 9230683-20 

If you have any recommendations or suggestions for improvement, kindly share your thoughts with us on 

technic@novalnet.de or call us at +49 89 9230683-19.  

Are you happy with our service and support? Please spend a few minutes to share your success here. 

For our License details see for Freeware License Agreement. 
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